PHP5 - GD for Drupal 6.x

While installing some Image modules in Drupal I get the message:

GD Image Filtering Low Quality / Poor Performance
The installed version of PHP GD does not support image filtering(desaturate, blur, negate, etc). It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See http://www.php.net/manual/en/image.setup.php. An implementation of imagefilter in PHP will be used in the interim.

and:

GD Image Rotation Low Quality / Poor Performance
The installed version of PHP GD does not support image filtering(desaturate, blur, negate, etc). It was probably compiled using the official GD libraries from http://www.libgd.org instead of the GD library bundled with PHP. You should recompile PHP --with-gd using the bundled GD library. See http://www.php.net/manual/en/image.setup.php. An implementation of imagefilter in PHP will be used in the interim.

No images are made and ImgeCache does not show the Preview image.
To solve this problem there are two option:

-1- Install ImageMagick and choose Imgemagick in ImageAPI

-2- You have tot install the PHP5-gd library. Unfortunately is the php5-gd lib from the Ubuntu repository (apt-get install php5-gd) not a solution. You need to install de lib from dotdeb.org.

Note: You have to be Super User to do this.

This is how you do that.

Step 1: remove the php5-gd lib that is installed on your system

sudo apt-get remove --purge php5-gd

Step 2: add dotdeb.org to your apt-get source file.
Open (as sudo) your /etc/apt/sources.lst with your favourite text editor and add those line somewhere in the file:

Step 3: Update apt

sudo apt-get update

Step 4: Install php5-gd

sudo apt-get install php5-gd

Step 5: Restart apache

sudo apache2ctl graceful

Now images are made correct in Drupal

Post new comment
The content of this field is kept private and will not be shown publicly.
CAPTCHA
Deze vraag is om te controleren of u een persoon bent. Di is om spam berichten tegen te gaan.